Support for pg_trgm Module

JFrog Installation & Setup Documentation

ft:sourceType
Paligo

Starting from Xray 3.70.x versions, Xray utilizes the pg_trgm PostgreSQL module, which enhances Xray's performance. If you are using an external postgresql and this extension is not already installed, please install them manually.

This extension is not packaged until Xray version 3.84.x. If you are performing an upgrade from a previous xray version and if you are using bundled PostgreSQL, you will need to install the necessary packages manually based on the PostgreSQL version currently installed.

1) Determine the version of bundled PostgreSQL currently installed.

2) Visit the official PostgreSQL repository for RHEL/CentOS at the following URL: https://download.postgresql.org/pub/repos/yum/

3) Download the appropriate PostgreSQL .contrib package version and install them.