Upgrading from Xray Version 3.x to 3.x

JFrog Installation & Setup Documentation

ft:sourceType
Paligo

The following upgrade methods are supported:

Upgrading to Xray 3.70.x - 3.84.x

Starting from Xray 3.70.x versions, Xray utilizes the pg_trgm PostgreSQL extension, which enhances Xray performance. This extension is not packaged until Xray version 3.84.x. If you are using an external PostgreSQL and this extension is not already installed, install the extension manually. For more information, see Support for pg_trgm Module

Upgrading from Xray 3.71 to Higher Versions in Debian and Red Hat Installations

When you upgrade from Xray 3.71 to higher versions, Xray service might not come up after installation. This is because of an incompatible Erlang package in RabbitMQ. You must remove the Erlang package from your installation before you proceed with the upgrade.

If you upgraded to a higher version, run the following commands:

dpkg --purge --force-all esl-erlang
cd jfrog-xray-<version>-deb/third-party/rabbitmq
dpkg -i esl-erlang_23.2.3-1_ubuntu_bionic_amd64.deb
systemctl start xray.service

Upgrading from Xray 3.16.2 to 3.69.3 in Debian Installations

When you upgrade from Xray 3.16.2 to higher versions, Xray service might not come up after installation. This is because of an incompatible Erlang package in RabbitMQ. You must remove the Erlang package from your installation before you proceed with the upgrade.

If you upgraded to a higher version, run the following commands.

dpkg --purge --force-all esl-erlang
cd jfrog-xray-<version>-deb/third-party/rabbitmq
dpkg -i esl-erlang_23.2.3-1_ubuntu_bionic_amd64.deb
systemctl start xray.service

RabbitMQ Upgrade to version 3.11.x and later

Xray version 3.70.0 and later includes RabbitMQ version 3.11.x later. An upgrade to Rabbit MQ 3.11.x requires feature flags to be enabled. For more information, refer to Required Feature Flags in RabbitMQ 3.11.0.