Xray: How to resolve report row limit error?

Xray: How to resolve report row limit error?

AuthorFullName__c
Andrey Granovsky
articleNumber
000005058
ft:sourceType
Salesforce
FirstPublishedDate
2021-05-04T15:33:53Z
lastModifiedDate
2024-03-10T07:45:24Z
VersionNumber
4
Issue
This article explains how to resolve the error "failed to generate report for report ##: report rows limit reached" when creating a report in Xray.
 
Cause
The cause of this error is the row limit configured in Xray, if the generated report has more rows than the limit, the report will not be generated and the error above will be shown in xray-server-service.log. In most versions, the default row limit is 100k.
 
Resolution
In order to change the row limit, the parameter server.reports.rowLimit in Xray's system.yaml file (located in $JFROG_HOME/xray/var/etc/) need to be added/modified accordingly (Change <MAX_ROW_NUMBER> to the desired value). In the below example, the limit is now 200k:
## XRAY SERVER TEMPLATE

server:

  reports:

    rowsLimit: 200000