JFROG PLATFORM: Verified Client versions for the JFrog Platform release

Saleh Samara
2023-01-22 11:11

For enhanced security and compliance, your JFrog Platform only supports clients that support 302 HTTP redirects for various package types, when working with JFrog Cloud. This is due to the fact that download requests using clients that don't support 302 redirects will fail in most instances when using the following package types: Bower, Composer, Conan, Cran, Debian, Docker, Git LFS, Gradle, Helm, Maven, npm, PyPI, RPM, Vagrant, and generic. An example use case of an outdated client not supporting HTTP redirects can be found HERE

Approved clients 

For your reference, the following list of client versions have been tested on the JFrog Platform and verified for 302 HTTP redirect support.

 

Package Type

Client Version

Bower

1.8.0

Composer

1.0.0

Conan

1.0.4

Cran

3.4.0

Debian

7

Docker

17.03.2

Git LFS

1.5.6

Gradle

4.10.3

Helm

2.5.0

Maven

3.3.9

npm

5.10.0

PyPI

8.0.0

RPM

6

Vagrant

2.0.2

 

Note: Some older client versions may also support 302 HTTP redirects, however, it is best practice to use the verified versions above.