ARTIFACTORY: Why will Artifactory pods fail with the error cp: cannot stat '/artifactory_bootstrap/binarystore.xml': No such file or directory

AuthorFullName__c
Haritha Arumugam
articleNumber
000005594
FirstPublishedDate
2023-03-01T17:27:11Z
lastModifiedDate
2025-07-22

ARTIFACTORY: Why will Artifactory pods fail with the error cp: cannot stat '/artifactory_bootstrap/binarystore.xml': No such file or directory



During the Artifactory upgrade to version 7.46.x (Helm charts version 107.46.x) we may be noticing the error about binarystore when using the custom binarystore. The log would show the error “cp: cannot stat '/artifactory_bootstrap/binarystore.xml': No such file or directory”.

Example error snippet:

 User-added image

 

The reason behind this issue: 

From Artifactory version 7.46.x (Helm charts version 107.46.x), binarystore.xml is copied to etc/artifactory in the copy-system-configurations init container. Therefore, it's not required to use copyOnEveryStartup parameter for configuring binarystore.xml.

How to overcome this behavior:

It is recommended to comment copyOnEveryStartup parameter from custom-binarystore.yaml and then perform the Artifactory upgrade.

"helm upgrade --install artifactory --version <version> --namespace <namespace> jfrog/artifactory -f custom-values.yaml -f custom-binarystore.yaml "


User-added image