Under certain circumstances, users may encounter an issue in which pulling some docker images via Artifactory, that were once successful, fails with an "error pulling image configuration: unknown blob" error. This behavior could usually occur if the image pull has been interrupted in the middle (due to manual intervention or unstable network connection), the remote cache was deleted, and the client had a partial cache. These conditions have led to this error when attempting to pull these images again:

Artifactory version 7.41 has introduced a fix in which applying a system property allows Artifactory to serve these affected images. This feature is disabled by default and the following system property should be added to the $JFROG_HOME/artifactory/var/etc/artifactory/artifactory.system.properties file in order to enable it (in HA setups, this should be added in each of the nodes):
artifactory.docker.remote.blob.streaming.enabled=true
For the changes to take effect, Artifactory must be restarted.
Known limitation - this implementation has a limitation in which the images will be successfully pulled via Artifactory, however, the layers will not be visible in the UI.
Possible workaround:
In circumstances when an upgrade is not immediately feasible, pulling the images using a new docker client that has not yet been used to pull these images should allow successfully resolving these images.