ARTIFACTORY: How to Configure Hitachi Content Platform (HCP) S3 for Artifactory Filestore

ARTIFACTORY: How to Configure Hitachi Content Platform (HCP) S3 for Artifactory Filestore

Products
Frog_Artifactory
Content Type
Installation_Setup
AuthorFullName__c
Valeriy Petrov
articleNumber
000006476
FirstPublishedDate
2025-06-17T08:29:54Z
lastModifiedDate
2025-06-17
VersionNumber
1
Issue

When using Hitachi Content Platform (HCP) S3 bucket as your Artifactory filestore, you may encounter problems when deploying or updating artifacts.


You may see a variety of error messages in your Artifactory logs, all pointing to a similar issue. These can include:
  • A "Bad Request" error when Artifactory tries to deploy internal  jfrog-usage-logs.
  • Log messages indicating a failure to deploy, such as: Cannot deploy to '{jfrog-usage-logs:New/artifactory/...
  • A 400 { "errors": [{"status": 400, "message": "Bad Request" }]}  error when uploading a file.
  • An error message from S3 showing a conflict: Service: Amazon S3; Status Code: 409; Error Code: Operation Aborted
Cause

These errors occur because Artifactory expects to be able to overwrite files, but the default Hitachi S3 configuration blocks this.


By default, the Hitachi S3 API is configured to reject any request to PUT (or upload) a file if the file with the same name already exists. When this happens, it sends back a 409 Conflict error. Artifactory often replaces binaries and isn't expecting this response from its storage, which leads to a failure.


Resolution


To resolve this, we need to change a setting on your Hitachi S3 bucket.


The solution is to enable versioning on the bucket you are using for your Artifactory filestore.


When versioning is enabled, Hitachi HCP will now accept requests to modify an object. Instead of trying to overwrite the existing file (which it won't do), it will create a new version of that file. This approach satisfies Artifactory's need to update binaries and resolves the 409 Conflict error.


Once you enable versioning on the bucket, the deployment and overwrite errors in Artifactory will stop. This is a required configuration step when using Hitachi HCP S3 as your Artifactory backend due to its unique default settings.